Zum Inhalt springen
BeispielWerk
English

URLs für Tests: gültige und ungültige Adressen

Eine URL setzt sich aus Schema, Host, optionalem Port, Pfad und Query zusammen. Die Beispiele decken Varianten wie www, explizite Standardports, abschließenden Schrägstrich, leere Query-Parameter, localhost, FTP und Git-SSH ab, dazu bewusst ungültige Schreibweisen. Die meisten Adressen basieren auf example.com, einer für Beispiele reservierten Domain (RFC 2606), dazu kommen localhost, .test-Domains und Dokumentations-IPs (RFC 5737, RFC 3849).

41 Varianten auf einer Seite, jede mit eigenem Kopier- oder Download-Knopf. Darunter: 30× Reservierter Bereich, 8× Absichtlich ungültig.

  • URL: Einfache URL mit wwwReservierter Bereich

    https://www.example.com

    Einfache URL mit www. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Unverschlüsselt, ohne wwwReservierter Bereich

    http://example.com

    Unverschlüsselt, ohne www. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Mehrstufiger PfadReservierter Bereich

    https://example.com/produkte/schuhe/laufschuhe-herren

    Mehrstufiger Pfad. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Mehrere Query-ParameterReservierter Bereich

    https://example.com/suche?q=laufschuhe&sort=preis&seite=2

    Mehrere Query-Parameter. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Query-Parameter als ArrayReservierter Bereich

    https://example.com/filter?farbe[]=rot&farbe[]=blau&groesse=42

    Query-Parameter als Array. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Leerer Query-ParameterReservierter Bereich

    https://example.com/suche?q=

    Leerer Query-Parameter. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Prozent-kodierter Umlaut (ü) und Plus als LeerzeichenReservierter Bereich

    https://example.com/suche?q=gr%C3%BCne+Schuhe

    Prozent-kodierter Umlaut (ü) und Plus als Leerzeichen. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Mit Fragment (Anker)Reservierter Bereich

    https://example.com/hilfe#kontakt

    Mit Fragment (Anker). Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Query und Fragment kombiniertReservierter Bereich

    https://example.com/artikel?id=42#kommentare

    Query und Fragment kombiniert. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Mit PortReservierter Bereich

    https://example.com:8443/admin

    Mit Port. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Standardport explizit angegebenReservierter Bereich

    http://example.com:80/

    Standardport explizit angegeben. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Mit Zugangsdaten in der URL (Platzhalter, nicht verwenden)Reservierter Bereich

    https://nutzer:passwort@example.com/geschuetzt

    Mit Zugangsdaten in der URL (Platzhalter, nicht verwenden). Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: IPv4 aus dem Dokumentationsbereich (RFC 5737)Reservierter Bereich

    http://192.0.2.1/status

    IPv4 aus dem Dokumentationsbereich (RFC 5737). Der Bereich 192.0.2.0/24 ist für Dokumentation reserviert.

  • URL: IPv6-Literal aus dem Dokumentationsbereich (RFC 3849)Reservierter Bereich

    http://[2001:db8::1]/

    IPv6-Literal aus dem Dokumentationsbereich (RFC 3849). Das Präfix 2001:db8::/32 ist für Dokumentation reserviert.

  • URL: IPv6-Literal mit PortReservierter Bereich

    http://[2001:db8::1]:8080/api

    IPv6-Literal mit Port. Das Präfix 2001:db8::/32 ist für Dokumentation reserviert.

  • URL: Lokale EntwicklungReservierter Bereich

    http://localhost:3000/

    Lokale Entwicklung. localhost verweist auf den eigenen Rechner und ist reserviert (RFC 6761).

  • URL: Loopback-AdresseReservierter Bereich

    http://127.0.0.1:8080/health

    Loopback-Adresse. Verweist auf den eigenen Rechner (RFC 1122).

  • URL: Punycode-Darstellung von bücher.testReservierter Bereich

    https://xn--bcher-kva.test/

    Punycode-Darstellung von bücher.test. Die TLD .test ist für Tests reserviert (RFC 2606, RFC 6761).

  • URL: IDN mit Umlaut unter .testReservierter Bereich

    https://bücher.test/

    IDN mit Umlaut unter .test. Die TLD .test ist für Tests reserviert (RFC 2606, RFC 6761).

  • URL: Mehrstufige SubdomainReservierter Bereich

    https://app.eu-west.example.com/

    Mehrstufige Subdomain. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Mit abschließendem SchrägstrichReservierter Bereich

    https://example.com/pfad/

    Mit abschließendem Schrägstrich. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Link auf eine DateiReservierter Bereich

    https://example.com/downloads/bericht-2026.pdf

    Link auf eine Datei. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Protokollrelative URLReservierter Bereich

    //example.com/bild.png

    Protokollrelative URL. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Relativer Pfad mit Query

    /produkte/neu?seite=1

    Relativer Pfad mit Query. Ohne Host; wird relativ zur aktuellen Seite aufgelöst.

  • URL: mailto-Link mit Betreff und TextReservierter Bereich

    mailto:kontakt@example.com?subject=Anfrage&body=Guten%20Tag

    mailto-Link mit Betreff und Text. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: FTP-URLReservierter Bereich

    ftp://example.com/pub/datei.txt

    FTP-URL. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Data-URI mit Text

    data:text/plain;charset=utf-8,Hallo%20Welt

    Data-URI mit Text. Enthält keinen Host; der Inhalt steht in der URL selbst (RFC 2397).

  • URL: Lokale Datei-URL

    file:///tmp/beispiel.txt

    Lokale Datei-URL. Verweist auf eine lokale Datei, nicht auf einen Server.

  • URL: Umlaute und ß direkt im PfadReservierter Bereich

    https://example.com/über-uns/größe

    Umlaute und ß direkt im Pfad. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Prozent-kodiertes LeerzeichenReservierter Bereich

    https://example.com/meine%20datei.pdf

    Prozent-kodiertes Leerzeichen. Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Git-SSH-Adresse (scp-Stil)Reservierter Bereich

    git@example.com:team/projekt.git

    Git-SSH-Adresse (scp-Stil). Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Sehr lange URL (rund 500 Zeichen)Reservierter Bereich

    https://example.com/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/pfad/ …

    Sehr lange URL (rund 500 Zeichen). Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Lange URL (über 2000 Zeichen)Reservierter Bereich

    https://example.com/?q=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa …

    Lange URL (über 2000 Zeichen). Basiert auf example.com (RFC 2606): die Domain ist für Beispiele reserviert.

  • URL: Ohne SchemaAbsichtlich ungültig

    example.com/pfad

    Absichtlich ungültig – ohne schema.

  • URL: Leerzeichen im PfadAbsichtlich ungültig

    https://example.com/pfad mit leerzeichen

    Absichtlich ungültig – leerzeichen im pfad.

  • URL: Nur ein Schrägstrich nach dem SchemaAbsichtlich ungültig

    https:/example.com

    Absichtlich ungültig – nur ein schrägstrich nach dem schema.

  • URL: Tippfehler im SchemaAbsichtlich ungültig

    htp://example.com

    Absichtlich ungültig – tippfehler im schema.

  • URL: Port außerhalb 0–65535Absichtlich ungültig

    https://example.com:99999/

    Absichtlich ungültig – port außerhalb 0–65535.

  • URL: Leerzeichen in der DomainAbsichtlich ungültig

    https://exa mple.com

    Absichtlich ungültig – leerzeichen in der domain.

  • URL: Domain fehltAbsichtlich ungültig

    https:///pfad

    Absichtlich ungültig – domain fehlt.

  • URL: javascript:-URL, die Filter ablehnen solltenAbsichtlich ungültig

    javascript:void(0)

    Absichtlich ungültig – javascript:-url, die filter ablehnen sollten.

Weitere Themen in E-Mail, Telefon & Web